coreBOS OpenSourceBT

View Issue Details Jump to Notes ] Wiki ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000368coreBOSBugpublic2019-01-14 17:332019-01-16 23:37
Reporterstudiosg 
Assigned Tojoebordes 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000368: Cannot add new users
DescriptionI recently (January 3) installed a current version of corebos, then logged-in as admin and run the cbupdater in order to have the latest code available. Then I tried adding some real users, but could not. To make a long story short I noticed that the "Password" and "Confirm Password" fields where not appearing in the DetailView form while in Edit mode. Both fields are required ones and the data consistency check fails when they are not filled-in.
Steps To Reproduce* Execute a fresh install cloning the code from the GitHub repository.
* Connect as user Admin
* Run the updater.
* Go to Settings -> Users
* Try adding a new user
* Press the save button
Nothing happens.
Additional InformationI found out function getBlocks in include/utils/CommonUtils.php was changed introducing a new check: $display_type_check. The check filters for vtiger_field.displaytype = 1 (Show always) but Password and Confirm Password have displaytype = 4 (Show only in insert mode). I updated the getBlocks code adding 4 to the filter. I'm uploading the related patch.
TagsNo tags attached.
Attached Filesbz2 file icon 0001-Solve-bug-preventing-adding-users.txt.bz2 [^] (755 bytes) 2019-01-14 17:33

- Relationships

-  Notes
User avatar (0000578)
joebordes (manager)
2019-01-14 19:17

Have you clicked on the "Load Updates" button first? Are there actually changesets loaded and applied (besides the continuous ones)?

This problem was solved a very long time ago and the other issue you are reporting looks like you haven't applied the latest changesets.
User avatar (0000581)
joebordes (manager)
2019-01-14 19:47

I just installed coreBOS from scratch and created a user with no problem.

Click on the "load updates" button and try again

Let me know how it goes
User avatar (0000582)
studiosg (reporter)
2019-01-16 22:20

Thanks for the prompt response.

I tried a fresh install and update. Works perfectly. I'm sorry for the fake report. I probably did something wrong while updating the first time.
User avatar (0000584)
joebordes (manager)
2019-01-16 23:37

No problem at all :-)

I would like to invite you to join our gitter channel, that has a bit more movement than this issue tracker which I will take down in the near future in favor of centralizing on github.

http://gitter.im/corebos [^]

- Issue History
Date Modified Username Field Change
2019-01-14 17:33 studiosg New Issue
2019-01-14 17:33 studiosg File Added: 0001-Solve-bug-preventing-adding-users.txt.bz2
2019-01-14 19:17 joebordes Note Added: 0000578
2019-01-14 19:47 joebordes Note Added: 0000581
2019-01-16 22:20 studiosg Note Added: 0000582
2019-01-16 23:37 joebordes Note Added: 0000584
2019-01-16 23:37 joebordes Status new => closed
2019-01-16 23:37 joebordes Assigned To => joebordes
2019-01-16 23:37 joebordes Resolution open => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker