coreBOS OpenSourceBT

View Issue Details Jump to Notes ] Wiki ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000356coreBOSBugpublic2017-01-24 10:122017-01-30 13:04
Reporterpolanskiman 
Assigned Tojoebordes 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionreopened 
PlatformSynologyOSDSMOS Version6.0.2
Product Version 
Target VersionFixed in Version 
Summary0000356: Moving menu items in the Menu tree then saving doesn't hold their position
DescriptionMoving menu items in the Menu tree then saving doesn't hold their position in the tree.
Steps To ReproduceDrag and drop a menu item across the tree then save.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0000534)
joebordes (manager)
2017-01-26 09:50

I cannot reproduce this.
Maybe related to the table dump done in 0000355
make sure the _seq table is set correctly
User avatar (0000535)
polanskiman (updater)
2017-01-26 12:34
edited on: 2017-01-26 12:45

Sorry to re-open this.
1 - Which _seq table? I don't see any vtiger_evvtmenu_seq nor any vtiger_seq table. I migh not be looking in the right place maybe...
2 - How do I make sure the _seq table is set correctly?

User avatar (0000536)
joebordes (manager)
2017-01-27 13:26

Sorry, my bad. I thought that table would have an associated _evvtmenu_seq table but the evvtmenuid field is autoincrmental
I don't know, try manuallt inserting a record in the table with no evvtmenuid specified to see if you get some error message....
User avatar (0000537)
polanskiman (updater)
2017-01-30 04:41

Inserting a record with no evvtmenuid does not produce any error message. The evvtmenuid number is automatically generated and autoincremented.

I made a video to show what the problem is in case I was not clear before:
https://youtu.be/Lnts663GCoo [^]

I don't think the issue is related to the table dump that was done earlier as this also happens on a fresh install of COREbos with a fresh unedited database.
User avatar (0000538)
joebordes (manager)
2017-01-30 10:32

I can't see the video, youtube says I don't have permission
User avatar (0000539)
polanskiman (updater)
2017-01-30 11:42
edited on: 2017-01-30 11:42

Video fixed. It was mistakenly on private.

User avatar (0000540)
joebordes (manager)
2017-01-30 12:58

Fix committed to master branch. d0be9ad3c99a88ccec4f3338ea23a308aa8bc377
User avatar (0000541)
joebordes (manager)
2017-01-30 13:04

Got it. The ordering code was incorrect. You will have to manually update the sequence in your database to get it working correctly

- Related Changesets
coreBOS: master d0be9ad3
Timestamp: 2017-01-30 12:58:06
Author: joebordes
Details ] Diff ]
fix(Menu) correct sql updates for reordering. fixes 0000356
mod - modules/evvtMenu/Save.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-01-24 10:12 polanskiman New Issue
2017-01-26 09:50 joebordes Note Added: 0000534
2017-01-26 09:50 joebordes Status new => closed
2017-01-26 09:50 joebordes Assigned To => joebordes
2017-01-26 09:50 joebordes Resolution open => fixed
2017-01-26 12:34 polanskiman Note Added: 0000535
2017-01-26 12:34 polanskiman Status closed => feedback
2017-01-26 12:34 polanskiman Resolution fixed => reopened
2017-01-26 12:45 polanskiman Note Edited: 0000535 View Revisions
2017-01-27 13:26 joebordes Note Added: 0000536
2017-01-30 04:41 polanskiman Note Added: 0000537
2017-01-30 04:41 polanskiman Status feedback => assigned
2017-01-30 10:32 joebordes Note Added: 0000538
2017-01-30 11:42 polanskiman Note Added: 0000539
2017-01-30 11:42 polanskiman Note Edited: 0000539 View Revisions
2017-01-30 12:58 joebordes Changeset attached => coreBOS master d0be9ad3
2017-01-30 12:58 joebordes Note Added: 0000540
2017-01-30 12:58 joebordes Status assigned => resolved
2017-01-30 13:04 joebordes Note Added: 0000541


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker