coreBOS OpenSourceBT

View Issue Details Jump to Notes ] Wiki ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000355coreBOSBugpublic2017-01-23 06:192017-01-24 09:49
Reporterpolanskiman 
Assigned Tojoebordes 
PriorityhighSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformSynologyOSDSMOS Version6.0.2
Product Version5.4 
Target VersionFixed in Version 
Summary0000355: Menu Layout unable to load in Menu editor after deletion of a Menu Item
DescriptionThe Menu Layout tree is unable to load in Menu editor module after a default Menu Item is deleted.
Steps To ReproduceGo to Menu editor. Select a default folder say the Marketing folder on the Menu Layout tree on the left. Now click the red Delete button. After the page finishes reloading the Menu Layout tree is not loading anymore and we see this endless turning icon Loading ...
Additional InformationDeletion of custom made Menu Items is also impossible.
TagsNo tags attached.
Attached Filesjpg file icon Screen Shot 2017-01-23 at 12.17.45 PM.jpg [^] (68,311 bytes) 2017-01-23 06:19

- Relationships

-  Notes
User avatar (0000528)
joebordes (manager)
2017-01-23 16:37

Fix committed to master branch. b2d7522bfbed7e100b2cd54cdd7b2eb2a7cf1988
User avatar (0000529)
joebordes (manager)
2017-01-23 22:49

thanks!
User avatar (0000530)
polanskiman (updater)
2017-01-24 05:18
edited on: 2017-01-24 07:19

Applying the fix did not seem to resolve the issue. I still see the endless turning icon Loading ... and the menu items can't be deleted.

User avatar (0000531)
joebordes (manager)
2017-01-24 08:34

It is probably because you have one or more orphaned menu entries. The top level delete was broken, so it deleted the top level menu but left the orphaned sub-entries. Now it is probably seeing those and doesn't know what to do with them.
You will have to look in the database and manuallt find and delete those lose entries.
Look in the table vtiger_evvtmenu for records that have a mparent bigger than 0 that does not exist.
This SQL will probably get the strayed entries:
SELECT * FROM `vtiger_evvtmenu` WHERE mparent not in (select `evvtmenuid` from vtiger_evvtmenu) and mparent 
> 0


Let me know how it goes
User avatar (0000532)
polanskiman (updater)
2017-01-24 09:35
edited on: 2017-01-24 09:40

I saw your note a bit too late. I actually solved the issue by:

1 - Dropping the entire vtiger_evvtmenu table on the database
2 - Installing a new instance of corebos with a new database
3 - Copying the brand new vtiger_evvtmenu table to the old database.

Not a very efficient method but at least I am sure the table is free of any defect.

Deleting Menu Item now doesn't seem to pose any problems.

Case closed.

Thanks Joe.

PS: I tried your sql query on a test database where I also had the problem and it worked fine.

User avatar (0000533)
joebordes (manager)
2017-01-24 09:49

That procedure sounds like it should work too :-)

Glad we got it working!

- Related Changesets
coreBOS: master b2d7522b
Timestamp: 2017-01-23 16:37:10
Author: joebordes
Details ] Diff ]
fix(Menu) incorrect variable broke menu branch delete. fixes 0000355
mod - modules/evvtMenu/Save.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2017-01-23 06:19 polanskiman New Issue
2017-01-23 06:19 polanskiman File Added: Screen Shot 2017-01-23 at 12.17.45 PM.jpg
2017-01-23 07:52 polanskiman Additional Information Updated View Revisions
2017-01-23 07:55 polanskiman Description Updated View Revisions
2017-01-23 07:55 polanskiman Steps to Reproduce Updated View Revisions
2017-01-23 16:37 joebordes Changeset attached => coreBOS master b2d7522b
2017-01-23 16:37 joebordes Note Added: 0000528
2017-01-23 16:37 joebordes Assigned To => joebordes
2017-01-23 16:37 joebordes Status new => resolved
2017-01-23 16:37 joebordes Resolution open => fixed
2017-01-23 22:49 joebordes Note Added: 0000529
2017-01-24 05:18 polanskiman Note Added: 0000530
2017-01-24 05:18 polanskiman Status resolved => feedback
2017-01-24 05:18 polanskiman Resolution fixed => reopened
2017-01-24 07:19 polanskiman Note Edited: 0000530 View Revisions
2017-01-24 08:34 joebordes Note Added: 0000531
2017-01-24 09:35 polanskiman Note Added: 0000532
2017-01-24 09:35 polanskiman Status feedback => assigned
2017-01-24 09:35 polanskiman Note Edited: 0000532 View Revisions
2017-01-24 09:40 polanskiman Note Edited: 0000532 View Revisions
2017-01-24 09:49 joebordes Note Added: 0000533
2017-01-24 09:49 joebordes Status assigned => resolved
2017-01-24 09:49 joebordes Resolution reopened => fixed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker